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Introduction
XLIFF Manager provides an open source UI for OpenXLIFF Filters, a set of programs that let you:

• Create XLIFF 1.2, 2.0 and 2.1 files that can be translated in any modern CAT tool.

• Convert your translated XLIFF files to original format with a couple of clicks.

• Validate XLIFF files created by any tool. Validation is supported for XLIFF 1.0, 1.1, 1.2 and 2.0.

• Produce anHTML file withword counts and segment status statistics froman XLIFF document.

Supported File Formats
With XLIFF Manager you can create XLIFF files from the following document formats:

Software DevelopmentGeneral Documentation

• JavaScript• Adobe InCopy ICML

• Adobe InDesign Interchange (INX) • Java Properties

• JSON• Adobe InDesign IDML CS4, CS5, CS6 & CC

• HTML • PHP Arrays

• PO (Portable Objects)• Microsoft Office 2007/2008/2010/2011/2013/2016

• Microsoft Visio XML Drawings 2007/2010/2013 • RC (Windows C/C++
Resources)• MIF (Maker Interchange Format)

• ResX (Windows .NET
Resources)• OpenOffice/LibreOffice/StarOffice 1.x/2.x/3.x/4.x/5.x

• Plain Text
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Software DevelopmentGeneral Documentation

• TS (Qt Linguist Translation
Source)

• Trados Studio Packages

• SDLXLIFF (Trados Studio)

• SRT Subtitles

• Wordfast/GlobalLink TXML (*.txml)

• Wordfast/GlobalLink XLIFF (*.txlf)

• WPML XLIFF (WordPress Multilingual Plugin)

• XLIFF from Other Tools (*.mqxliff, *.xliff)

• XML (Generic)

• XML with ready to use configuration files for:

– DITA 1.0, 1.1, 1.2 and 1.3

– DocBook 3.x, 4.x and 5.x

– SVG

– Word 2003 ML

– XHTML

The XML filter is customizable. Users can define conversion rules for almost any XML vocabulary.
Instructions for configuring the XML filter are available on GitHub, at XLIFF Filter Configuration
Files.

The JSON filter supports user-defined configuration files. Instructions for writing configuration
files are available on GitHub, at JSON Filter Configuration Files.

Supported Platforms
XLIFF Manager works on these platforms:

• Microsoft Windows 10 and 11

• macOS Monterey (12.0), Ventura (13.0) Sonoma (14.0) and Sequoia (15.0)

• Linux (with GNOME Desktop Manager)
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Creating and Merging XLIFF Files

Create XLIFF File

About this task
Use the Create XLIFF panel to generate an XLIFF file from a selected document.

Procedure
1. In main menu, select View → Create XLIFF or click the Create XLIFF option on the left

panel.

2. Type the name and location of the document to convert to XLIFF in the Source File text box
or click the Browse... button next to it to select a document from the file system.

Tip
If you use theBrowse... button to select a file, the program tries to automatically
guess its file type and character set.

3. Select the language of the document to convert using the Source Language drop-down list.

4. Optionally, select the language of the translated document using the Target Language
drop-down list.
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5. Select or adjust the type of source document using the File Type drop-down list.

6. Select or adjust the character set of the source document using the Character Set drop-down
list.

7. If you are converting a DITA map and need to use a .ditaval file for conditional filtering, enter
its path in theDITAVAL File text box or use the Browse... button next to it to select a file from
the file system.

8. Select the Ignore Translatable SVG Files checkbox if you are converting a DITA map and
need to exclude SVG files from the generated XLIFF.

9. If you are converting a JSON document and need to use a custom configuration file, enter its
name and location in the JSON Configuration text box or use the Browse... button next to it
to select a file from the file system.

Tip
Information on configuration files for the JSON filter is available at
https://github.com/rmraya/OpenXLIFF

10. Use the XLIFF Version radio buttons to select the version of XLIFF that you want to generate.

NOTICE
The program generates XLIFF 2.0 by default.

11. Select the Paragraph Segmentation checkbox if you want source text to be segmented at
paragraph level.

NOTICE
The program uses sentence-level segmentation by default. You can select the
default SRX file used for segmentation in the Settings dialog.

12. Select the Embed Skeleton checkbox if you want the skeleton file to be inserted in the
generated XLIFF.

NOTICE
The programgenerates a separated skeleton file in the folder defined in Settings
dialog. An embedded skeleton allows merging the XLIFF file in any computer,
not just the one where the XLIFF was generated.

13. Click the Create XLIFF button.
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Results
The program generates an XLIFF file and the corresponding skeleton.

Merge XLIFF File

About this task
Use the Merge XLIFF panel to convert an XLIFF file to original format.

XLIFF Manager can only merge XLIFF files that it generated or XLIFF files created with other tools
that use OpenXLIFF Filters.

Procedure
1. In main menu, select View → Merge XLIFF or click the Merge XLIFF option on the left

panel.

2. Type the name and location of the XLIFF file to merge in the XLIFF File text box or click the
Browse... button next to it to select an XLIFF file from the file system.

If you use the Browse... button to locate the XLIFF file, the program tries to automatically
generate a suitable target file or folder.

3. Type the name of the translated file or folder for translated documents in the Target
File/Folder text box or click the Browse... button next to it to select a file or folder.

If the XLIFF file contains multiple documents inside, a folder is required to place all translated
files in it. This is usually the case when the XLIFF was created from a DITA Map.
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4. Select the Accept Unapproved Segments checkbox if you want to consider all segments as
translated, even when the @approved attribute is not set to "yes".

5. Select the Export Approved Segments as TMX checkbox if you want to generate a TMX file
from the XLIFF file.

6. Select theOpen Translated File/Folder AfterMerging checkbox if youwant to automatically
open the translated document or folder after a successful merge operation.

7. Click theMerge XLIFF button.

XLIFF Manager merges the indicated file.
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Validate XLIFF

About this task
XLIFF Manager can validate XLIFF 1.0, 1.1, 1.2 and 2.0.

Validating XLIFF against XML grammars (DTD or XML Schemas) is not enough. XML Schema
validation does not detect the use of duplicated 'id' attributes, wrong language codes and other
constraints written in the different XLIFF specifications.

In addition to validating all XLIFF 2.0 modules using XML Schema validation, extra validation is
performed for XLIFF 2.0 Core and for Metadata, Matches and Glossary modules.

Procedure
1. In main menu, select View → Validate XLIFF or click the Validate XLIFF option on the left

panel.

2. Type the name and location of the XLIFF file to validate in the XLIFF File text box or click the
Browse... button to select an XLIFF file from the file system.

3. Click the Validate XLIFF button.

XLIFF Manager validates the indicated file.
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Generate Word Counts and Segment Statistics

About this task
XLIFFManager lets you produce an HTML file with word counts and segment status statistics from
an XLIFF document.

Procedure
1. In main menu, select View → Analyse XLIFF or click the Analyse XLIFF option on the left

panel.

2. Type the name and location of the XLIFF file to analyse in the XLIFF File text box or click the
Browse... button to select an XLIFF file from the file system.

3. Click the Analyse XLIFF button.

XLIFF Manager generates an HTML report in the folder where the XLIFF file is located and its
name is the name of the XLIFF plus .log.html.
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Translation Tasks
Use the options in the Translation Tasks panel to:

• Copy Source to all Untranslated Segments

• Pseudo-Translate Untranslated Segments

• Remove all Targets

• Approve all Segments

Copy Source to all Untranslated Segments
Copy the content of <source> elements to new or existing empty <target> elements in an XLIFF
file.

Procedure
1. In main menu, select View → Translation Tasks or click the Translation Tasks option on

the left panel.
2. Type the name and location of the XLIFF file to process in the XLIFF File text box or click the

Browse... button to select an XLIFF file from the file system.
3. Click the Copy Source to Target button.

Pseudo-Translate Untranslated Segments
Copy the content of <source> elements to new or existing empty <target> elements in an XLIFF
file, replacing all regular vowels with an accented version (e.g.: e => é).
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About this task
Use thismethod to generate a fake translation that you can use to test theMerge XLIFF File process.
After making sure that Merge runs successfully, you can use the Remove all Targets option to
clean your XLIFF file.

Procedure
1. In main menu, select View → Translation Tasks or click the Translation Tasks option on

the left panel.
2. Type the name and location of the XLIFF file to process in the XLIFF File text box or click the

Browse... button to select an XLIFF file from the file system.
3. Click the Pseudo-Translate button.

Remove all Targets
Use this feature to remove all <target> elements from your XLIFF file.

Procedure
1. In main menu, select View → Translation Tasks or click the Translation Tasks option on

the left panel.
2. Type the name and location of the XLIFF file to process in the XLIFF File text box or click the

Browse... button to select an XLIFF file from the file system.
3. Click the Remove all Targets button.

Approve all Segments
Set approved="true" in all <trans-unit> elements in an XLIFF 1.2 file or set state="final" in all
<unit> elements of an XLIFF 2.0 or 2.1 document.

About this task
Some translation tools do not offer away to confirm segments at translation time. Use this feature
to confirm all segments, so you can select the Export Approved Segments as TMX option when
using the Merge XLIFF File option.

Procedure
1. In main menu, select View → Translation Tasks or click the Translation Tasks option on

the left panel.
2. Type the name and location of the XLIFF file to process in the XLIFF File text box or click the

Browse... button to select an XLIFF file from the file system.
3. Click the Approve all Segments button.
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Settings
Use the Settings dialog to set the default languages used by the application and to configure the
main XML catalog and default folder used to store skeletons when creating XLIFF files.

Procedure
1. In main menu, select Settings (XLIFF Manager → Preferences on macOS) or click the

Settings option or on the left panel.

The following dialog appears:

2. Select the apropriate default source and target languages to use when creating XLIFF files.

3. If you wish to use a custom catalog for XML files, enter its location in the System Catalog text
box or use the corresponding Browse... button to select it from the file system.

4. If you wish to change the folder where skeleton files are saved, enter the folder name in the
Skeletons Folder text box or use the Browse... button to select the new location in the file
system.

5. To use a custom SRX file when creating XLIFF files, enter its location in the Default SRX File
text box or use the Browse... button to select it from the file system.

6. Use the Application Language drop-down to select the language used in XLIFF Manager
graphical user interface.

Changes to the application language will take effect after you restart the program.

7. Use the Theme drop-down to select the colors used in the graphical user interface. Available
options are:
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System Default: automatically selects Dark or Light colors according to the preferences
set in the operating system.

•

• Dark: Uses dark background with white text.

• Light: Uses light grey background with dark text

8. Click the Save Settings button.
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Subscriptions
Source code of XLIFF Manager is free. Anyone can download the source code from Github.com,
compile, modify and use it at no cost in compliance with the accompanying license terms.

Developing and maintaining a software project takes time, effort and resources. That is why we
offer subscriptions for support services such as technical assistance, bug fixes, and feature requests.
By subscribing to our support plan, you not only get access to our expertise and help, but you
also contribute to the continuous improvement of XLIFF Manager. Your subscription fees help us
pay for code development and ensure the quality and reliability of our software.

Subscription Keys are available atMaxprogramsOnline Store. Subscription Keys cannot be shared
or transferred to different machines.

Subscriptions include unlimited direct email support at tech@maxprograms.com

Register a Subscription Key
When you run the program without a registered subscription, the bottom of the screen shows a
Register Subscription link.

1. In main menu, select Help → Register Subscription or click the Register Subscription link
displayed at the bottom of the screen.

The Subscription Management dialog appears:

2. If you have a subscription key, type it in the Subscription Key text box and click the Register
Subscription button.

3. If you don't have a Subscrition Key andwish to purchase one, click thePurchase Subscription
button to open Maxprograms Online Store in your default web browser.
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Glossary
Computer Assisted Translation (CAT)

Computer technology application designed to assist human translators in the translation
process.

Character Set
A character set (sometimes referred to as code page) is a collection of characters that are
associated with a sequence of natural numbers in order to facilitate the storage of text
in computers and the transmission of text through telecommunication networks.

SRX

Segmentation Rules eXchange (SRX) is an XML-based standard that was maintained by
Localization Industry Standards Association, until it became insolvent in 2011, and then
by the Globalization and Localization Association (GALA).

SRX provides a common way to describe how to segment text for translation and other
language-related processes. It was created when it was realized that TMX was less useful
than expected in certain instances due to differences in how tools segment text. SRX is
intended to enhance the TMX standard so that translation memory (TM) data that is
exchanged between applications can be usedmore effectively. Having the segmentation
rules available that were used when a TMwas created increases the usefulness of the TM
data.

TMX
Translation Memory eXchange (TMX) is an open standard originally published by LISA
(Localization Industry Standards Association). The purpose of TMX is to allow easier
exchange of translationmemory data between tools and/or translation vendors with little
or no loss of critical data during the process.

XLIFF
XLIFF (XML Localization Interchange File Format) is an open standard developed byOASIS
(Organization for the Advancement of Structured Information Standards). The purpose
of this vocabulary is to store localizable data and carry it from one step of the localization
process to the other, while allowing interoperability between tools.
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