Contents

Introduction...........................................................................................................................................5
  Supported File Formats.........................................................................................................................5
  Supported Platforms.............................................................................................................................5
  Requirements.........................................................................................................................................5

Getting Started......................................................................................................................................7
  Step 1: Create a project...........................................................................................................................7
    Generate a project from two documents............................................................................................7
    Generate a project from a TMX file......................................................................................................8
  Step 2: Align extracted segments........................................................................................................8
  Step 3: Export aligned segments..........................................................................................................9
    Export as TMX....................................................................................................................................9
    Export as CSV....................................................................................................................................9
    Export as Trados TXT............................................................................................................................9
    Export as XLIFF...................................................................................................................................10

Editing TMX Files...............................................................................................................................11
  Import TMX File..................................................................................................................................11

User Interface......................................................................................................................................13
  Stingray GUI.........................................................................................................................................13
  Menus....................................................................................................................................................13
    File Menu.........................................................................................................................................13
    Edit Menu.........................................................................................................................................14
    Go To Menu.......................................................................................................................................15
    Options Menu...................................................................................................................................15
    Tasks Menu.......................................................................................................................................15
    Help Menu........................................................................................................................................15

License Management............................................................................................................................17
  Register a License Key........................................................................................................................17
  Disable a License Key..........................................................................................................................18
  Transfer a License Key........................................................................................................................18

Configuration Options.......................................................................................................................21
  User Interface...................................................................................................................................21
    Font Settings...................................................................................................................................21
    Shortcuts Configuration....................................................................................................................21
    Color Settings..................................................................................................................................21
  XML Filter Configuration..................................................................................................................22
    XML Catalog..................................................................................................................................22
    XML Converter................................................................................................................................25
  Language Codes...............................................................................................................................30
    Add Language..................................................................................................................................30
    Edit Language..................................................................................................................................30
Delete Language......................................................................................................................................31
Auto-Save Settings..............................................................................................................................................32

Glossary..........................................................................................................................................33
Introduction

Stingray is a cross-platform document aligner designed to assist professional translators in the production of translation memories from existing translated material.

Translation memories generated by Stingray can be used in most modern CAT (Computer Aided Translation) tools, including *Swordfish*.

**Supported File Formats**

The file formats currently supported by Stingray are:

<table>
<thead>
<tr>
<th>General documentation types</th>
<th>Software development types</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Abiword</td>
<td>• JavaScript</td>
</tr>
<tr>
<td>• Adobe InDesign Interchange (INX)</td>
<td>• Java Properties</td>
</tr>
<tr>
<td>• Adobe InDesign IDML (CS4 &amp; CS5)</td>
<td>• RC (Windows C/C++ Resources)</td>
</tr>
<tr>
<td>• HTML</td>
<td>• ResX (Windows .NET Resources)</td>
</tr>
<tr>
<td>• MIF (Maker Interchange Format)</td>
<td></td>
</tr>
<tr>
<td>• OpenOffice/StarOffice 1.x/2.x/3.x</td>
<td></td>
</tr>
<tr>
<td>• Plain Text</td>
<td></td>
</tr>
<tr>
<td>• RTF (Rich Text Format)</td>
<td></td>
</tr>
<tr>
<td>• XML (Generic)</td>
<td></td>
</tr>
<tr>
<td>• XML with ready to use configuration files for:</td>
<td></td>
</tr>
<tr>
<td>• DITA 1.0 and 1.1</td>
<td></td>
</tr>
<tr>
<td>• DocBook 3.x, 4.x and 5.x</td>
<td></td>
</tr>
<tr>
<td>• SVG</td>
<td></td>
</tr>
<tr>
<td>• Word 2003 ML</td>
<td></td>
</tr>
<tr>
<td>• XHTML</td>
<td></td>
</tr>
</tbody>
</table>

The filter for XML files supports custom configuration. Users can define conversion rules for almost any XML vocabulary.

**Supported Platforms**

- Microsoft Windows (7 and 8)
- Mac OS X 10.7/10.8 (Lion - Mountain Lion)
- Linux with GTK2 (i386 and x86_64)

**Requirements**

- Java 1.6/1.7 from Sun Microsystems or Oracle on Linux/Windows. Java 1.6 from Apple or Java 7 from Oracle on Mac OS X.
- WebKitGTK+ 1.2.x is required to run on Linux systems.

GNOME classic desktop manager is recommended for Linux. Some features may not work in other desktop managers.
Getting Started

Aligning is a process with 3 basic steps:

1. Create a project, selecting the documents to align or importing a TMX file.
2. Correct the alignment of the generated/imported segment pairs.
3. Export the aligned segments to a useful file format.

Step 1: Create a project

An alignment project can be created in two ways:

1. Processing two documents with similar structure to extract segment pairs. Use this option to create a new translation memory from a document and its translation.
2. Importing a TMX file. Use this option to correct the content of segments already defined by a translation tool.

Generate a project from two documents

1. In the File menu, select New Alignment Project or click the button. The following dialog appears:

   ![Alignment Project Dialog](image)

2. Enter the name of the alignment project file in the Project File text box or use the Browse... button next to it to select a name and location.
3. Select a source file and configure its properties in the Source File panel.
   a) Type the name of the source file in the File text box or use the Browse... button next to it to select a file from the operating system. If you use the Browse... button, the programs tries to automatically detect document type and character set.
   b) Select or correct the type of document in the File Type drop-down list.
   c) Select or correct the character set of the document in the Character Set drop-down list.
4. Select the file that contains the translations and configure its properties in the Translation panel.
   a) Type the name of the translation file in the File text box or use the Browse... button next to it to select a file from the operating system. If you use the Browse... button, the programs tries to automatically detect document type and character set.
b) Select or correct the type of document in the File Type drop-down list.
c) Select or correct the character set of the document in the Character Set drop-down list.

5. If you want to align paragraphs instead of sentences, check the Paragraph Segmentation box.
6. If you are processing plain text documents, verify their formatting and check the Break Segment on Every CR/LF (Plain Text) box.
7. Enter the name of the SRX file to use for segmenting the documents in the SRX Rules text box or use the Browse... button next to it to select an SRX file from the file system.
8. Click the Align Files button to create the project and display it in Stingray's main panel.

Generate a project from a TMX file

1. In the File menu, select Import TMX File.
   The following dialog appears:

2. Type the name of the TMX file to import in the TMX File text box or use the Browse... button next to it to select it from the file system.
3. Type the name of the alignment project to create in the Alignment Project text box or use the Browse... button next to it to select a name and location.
4. Click the Accept button to start creating the project.
   • If the selected TMX file does not have a defined source language, select it in the window that appears.
   • If the selected TMX file contains translations in more than two languages, select the target language in the window that appears.

A new alignment project is created from the data present in the selected TMX file.

Step 2: Align extracted segments

Use the buttons that appear below the alignment panel (the columns of text boxes), or their equivalent entries from the Edit menu, to correct the segments.
• Use the Move Segment Up and Move Segment Down buttons to move the segments up and down until they match the corresponding source/translation in the other column.
• Use the Split Segment button to split the text in the source or translation text box to match the counterpart in the other column.
• Use the Merge with Next Segment button to combine the text in the source or translation text box with the text of the following segment.
• Use the Delete Segment button to delete the selected source or translation segment.
• To edit the content of the source or translation text box, click the Edit Segment button and modify the text. Save your changes with the Accept Changes button or discard them using the Discard Changes button.
Step 3: Export aligned segments

Stingray can export aligned segments in four formats accepted by most translation tools:

- TMX 1.4
- CSV (Comma Separated Values)
- Trados TXT (7.x/8.x)
- XLIFF 1.2

Export as TMX

1. In the File menu, select Open File or click the button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as TMX.
4. Select a file name and location for storing the generated TMX file.
   A TMX file is generated and saved in the selected location.

Export as CSV

1. In the File menu, select Open File or click the button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as CSV.
4. Select the CSV file to generate.
   The following dialog appears:

   ![CSV Options dialog]

5. Type or select the column separator to use in the Column Separator drop-down list.
6. Type or select the text delimiter to use in the Text Delimiter drop-down list.
7. Select the character set to use in the Character Set drop-down list.
8. Click the Accept button.
   A delimited text file with the specified properties is created and saved in the selected location.

Export as Trados TXT

1. In the File menu, select Open File or click the button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as TXT (Trados 7.x/8x).
4. Select a file name and location for storing the generated TXT file.
   A TXT file for Trados 7.x/8x is generated and saved in the selected location.
Export as XLIFF

1. In the File menu, select Open File or click the button.
2. Locate and open the alignment project to be exported.
3. In the File menu, select Export Alignment Project as XLIFF.
4. Select a file name and location for storing the generated XLIFF file.

An XLIFF 1.2 file is generated and saved in the selected location.
Editing TMX Files

The steps for editing bilingual TMX files using Stingray are:

1. Import the TMX file into an Alignment Project;
2. Edit the Alignment Project;
3. Export the Alignment Project as TMX or a different format.

Important: all comments and properties stored in the TMX file are ignored when it is imported into an Alignment Project.

Import TMX File

1. In the File menu, select Open File or click the button.
2. Locate and open the TMX file to be imported.
   The following dialog appears:

3. In the Import TMX File dialog, verify the name of the TMX File and adjust the name and location of the Alignment Project to be generated.
4. In the Import TMX File dialog, click the Accept button to start the import process.
5. If the selected TMX file does not have a predefined source language, the following dialog will appear:

   a) In the Language Selection dialog, select the source language for the Alignment Project from the Source Language drop-down list.
   b) In the Language Selection dialog, click the Accept button.
6. If the selected TMX file contains data in more than two languages, the following dialog will appear:
a) In the **Language Selection** dialog, select the target language for the Alignment Project from the **Target Language** drop-down list.

b) In the **Language Selection** dialog, click the **Accept** button.

The selected TMX file is imported into an Alignment Project and opened in Stingray for editing.
User Interface

Stingray GUI

The following picture portrays Stingray:

![Stingray GUI](image)

Menus

File Menu

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Alignment Project</td>
<td>Create a new alignment project.</td>
</tr>
<tr>
<td>Open Alignment Project</td>
<td>Open an existing alignment project for editing.</td>
</tr>
<tr>
<td>Close Alignment Project</td>
<td>Close current open document.</td>
</tr>
<tr>
<td>Save Alignment Project</td>
<td>Save current open document.</td>
</tr>
<tr>
<td>Save Alignment Project As...</td>
<td>Save current open document under a new name.</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Export Alignment Project as TMX</td>
<td>Export aligned segments to a TMX 1.4 file for use in most CAT tools.</td>
</tr>
<tr>
<td>Export Alignment Project as CSV</td>
<td>Export aligned segments to a CSV (Comma Separated Values) file.</td>
</tr>
<tr>
<td>Export Alignment Project as TXT (Trados 7.x/8.x)</td>
<td>Export aligned segments to a TXT file suitable for use in Trados 7.x/8.x</td>
</tr>
<tr>
<td>Export Alignment Project as XLIFF</td>
<td>Export aligned segments to an XLIFF 1.2 file.</td>
</tr>
<tr>
<td>Import TMX File</td>
<td>Import a TMX file for editing in a new alignment project.</td>
</tr>
<tr>
<td>Preview as HTML</td>
<td>View aligned segments in a web browser.</td>
</tr>
<tr>
<td>Exit</td>
<td>Close the program.</td>
</tr>
</tbody>
</table>

**Edit Menu**

<table>
<thead>
<tr>
<th>Search/Replace</th>
<th>Open a dialog for searching/replacing text in source or translations.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Source Segment Up</td>
<td>Move selected source segment up one row.</td>
</tr>
<tr>
<td>Move Source Segment Down</td>
<td>Move selected source segment down one row.</td>
</tr>
<tr>
<td>Split Source Segment</td>
<td>Split source segment at current cursor position.</td>
</tr>
<tr>
<td>Merge Source Segment with Next</td>
<td>Combine current source segment with the following one.</td>
</tr>
<tr>
<td>Remove Source Segment</td>
<td>Remove source segment from list.</td>
</tr>
<tr>
<td>Edit Source Segment</td>
<td>Set source segment as editable to modify its content.</td>
</tr>
<tr>
<td>Save Changes to Source Segment</td>
<td>Save changes done to source segment.</td>
</tr>
<tr>
<td>Discard Changes to Source Segment</td>
<td>Discard the changes done to source segment and restore previous content.</td>
</tr>
<tr>
<td>Move Translation Segment Up</td>
<td>Move selected translation segment up one row.</td>
</tr>
<tr>
<td>Move Translation Segment Down</td>
<td>Move selected translation segment down one row.</td>
</tr>
<tr>
<td>Split Translation Segment</td>
<td>Split translation segment at current cursor position.</td>
</tr>
<tr>
<td>Merge Translation Segment with Next</td>
<td>Combine current translation segment with the following one.</td>
</tr>
<tr>
<td>Remove Translation Segment</td>
<td>Remove translation segment from list.</td>
</tr>
</tbody>
</table>
### Edit Translation Segment
Set translation segment as editable to modify its content.

### Save Changes to Translation Segment
Save changes done to translation segment.

### Discard Changes to Translation Segment
Discard the changes done to the translation segment and restore its previous content.

### Go To Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Segment</td>
<td>Display the previous segment.</td>
</tr>
<tr>
<td>Next Segment</td>
<td>Display the next segment.</td>
</tr>
<tr>
<td>First Segment</td>
<td>Display the first segment of the file.</td>
</tr>
<tr>
<td>Last Segment</td>
<td>Display the last segment of the file.</td>
</tr>
<tr>
<td>Got to segment...</td>
<td>Display a segment specified by its number.</td>
</tr>
</tbody>
</table>

### Options Menu

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Interface Configuration</td>
<td>Display a sub-menu for configuring font settings, keyboard shortcuts and system colors.</td>
</tr>
<tr>
<td>Catalog Manager</td>
<td>Display a dialog for editing the XML catalog used by the program when parsing XML files.</td>
</tr>
<tr>
<td>XML Converter Configuration</td>
<td>Display a dialog for configuring the translatable elements and attributes of an XML vocabulary.</td>
</tr>
<tr>
<td>Language Codes</td>
<td>Display a dialog for editing the existing language codes supported by the application.</td>
</tr>
<tr>
<td>Auto-Save Configuration</td>
<td>Display a dialog for selecting the automatic backup interval.</td>
</tr>
</tbody>
</table>

### Tasks Menu

<table>
<thead>
<tr>
<th>Task</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove all Tags</td>
<td>Remove markup information from all segments.</td>
</tr>
<tr>
<td>Remove Duplicate Entries</td>
<td>Remove all duplicated segments from the alignment project.</td>
</tr>
<tr>
<td>Remove Initial/Trailing Spaces</td>
<td>Remove leading and trailing spaces from all segments.</td>
</tr>
<tr>
<td>Change Language Codes</td>
<td>Display a dialog for changing source or target languages in the current alignment project.</td>
</tr>
</tbody>
</table>

### Help Menu

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stingray Help</td>
<td>Display Stingray User Guide in the default PDF viewer.</td>
</tr>
<tr>
<td>License Management</td>
<td>Display a dialog for licensing the program.</td>
</tr>
<tr>
<td>Check for Updates</td>
<td>Verify the availability of newer versions of the program.</td>
</tr>
<tr>
<td>About...</td>
<td>Display a dialog with license status and program version information.</td>
</tr>
</tbody>
</table>
License Management

A License Key is a short text code required to continue using the application after the 30 days evaluation period. License Keys can be purchased at [http://www.maxprograms.com/store/buy.html](http://www.maxprograms.com/store/buy.html)

**Note:**

- Registering or disabling a License Key requires an Internet connection.
- Registration data is sent to the server using TCP/IP protocol on port 9080. Open this port on your firewall during registration or the operation will fail.
- Always disable your license key before reformattting your hard disk or changing operating system.

Register a License Key

1. In the Help menu, select License Management.
   The following dialog appears:

2. Type your license code in the License Key text box.

3. If your computer uses a proxy server to connect to the Internet, follow these steps to configure the proxy server settings:
   a) Click the Proxy Settings button.
      The following dialog appears:

5. Type the proxy server name or IP in the Server text box.
   c) Type the proxy port number in the Port text box.
   d) If your proxy server requires authentication, type the proxy user name in the User ID text box and the corresponding password in the Password text box.
   e) Click the Accept button.

4. Click the Register License button.
5. Click the Close button.
Your license key code is sent to the Registration Server and your computer is enabled to work with the registered application.

**Disable a License Key**

1. In the Help menu, select License Management.
The following dialog appears:

2. If your computer uses a proxy server to connect to the Internet, follow these steps to configure the proxy server settings:
   a) Click the Proxy Settings button.
The following dialog appears:

   b) Type the proxy server name or IP in the Server text box.
   c) Type the proxy port number in the Port text box.
   d) If your proxy server requires authentication, type the proxy user name in the User ID text box and the corresponding password in the Password text box.
   e) Click the Accept button.

3. Click the Disable License button.
4. Click the Close button.
Your license key code is sent to the Registration Server and the application becomes disabled.

**Transfer a License Key**

Steps for transferring a working license key to a different computer.

1. Start the application in the computer where it is enabled.
2. Disable the license key.
3. Start the application in the computer that you want to use next.
4. Enable the license key.

Your license key is transferred from one computer to another.
Configuration Options

User Interface

Font Settings
1. In the Options menu, select User Interface Configuration.
2. In the User Interface Configuration sub-menu, select Font Settings.
3. In the font selection dialog, choose the default font, font style and font size to be used by the application.
Selected font will be used by the application to display text in relevant places.

Shortcuts Configuration
1. In the Options menu, select User Interface Configuration.
2. In the User Interface Configuration sub-menu, select Shortcuts Configuration.
The following dialog appears:

3. Use the scroll bar on the right side to locate the command that you want to modify.
4. Check the boxes for the modifier keys (Alt, Ctrl, Cmd or Shift) required in the new or modified shortcut.
5. Type a character or select a standard key in the drop-down-list on the right.
6. Repeat the previous 3 steps until all keyboard shortcuts have been configured as desired.
7. Click the Save button to save your changes or click the Load Defaults button to restore factory settings and restart the configuration task.
The requested changes are stored in the configuration file and become effective the next time the program is started.

Color Settings
1. In the Options menu, select User Interface Configuration.
2. In the User Interface Configuration sub-menu, select Color Settings.
The following dialog appears:
3. Locate the element that you want to modify and enter the RGB values for the desired color in the text box or click the Select... button to choose a new color using the default color selector widget from the operating system.

4. Repeat previous step until all colors have been adjusted.

5. Click the Accept button to save your changes.

XML Filter Configuration

The program needs to know two things for working with XML files:

- How to locate the grammar rules and entities declared in an XML file, if any.
- What elements and attributes contain translatable text.

XML catalogs that follow the specification published at http://www.oasis-open.org/committees/entity/spec-2001-08-06.html by OASIS are used to resolve the location of XML DTDs and Schemas.

Special XML files are used to configure the elements and attributes that contain translatable text. These files are used by the internal XML Converter to extract text for processing. The configuration files are created and maintained using the application’s graphical user interface.

XML Catalog

The application includes a default XML catalog with DTDs and XML Schemas for the most relevant localization formats and supported document types.

Additional DTDs and XML Schemas can be added by the user as needed.

Add Catalog Entry

1. In the Options menu, select Catalog Manager.

   The following dialog appears:
2. Click the **Add Entry** button.
The following dialog appears:

3. Select the appropriate entry type from the list.

4. Click the **Accept** button.

5. If the type of the new entry is "PUBLIC", the following dialog appears:

   a) Type the public id of the DTD in the **Public ID** text box.
   b) Type the location of the DTD, relative to the catalog, in the **URI** text box.
   c) Click the **Accept** button.

6. If type of the new entry is "SYSTEM", the following dialog appears:
a) Type the name of the DTD or XML Schema in the **System ID** text box.
b) Type the location of the DTD or XML Schema, relative to the catalog, in the **URI** text box.
c) Click the **Accept** button.

7. If type of the new entry is "URI", the following dialog appears:

a) Type the name of the URI in the **URI Name** text box.
b) Type the location of the corresponding DTD or XML Schema, relative to the catalog, in the **URI** text box.
c) Click the **Accept** button.

8. If the type of the new entry is "nextCatalog" a file selection dialog appears. Locate the catalog in the file system and save it.

9. Click the **Close** button to save your changes.

**Edit Catalog Entry**

1. In the **Options** menu, select **Catalog Manager**. The following dialog appears:

2. Select the entry to modify from the entry list.

3. Click the **Configure Entry** button. A dialog of the appropriate type for editing the selected entry appears.

4. Edit the properties of the entry.
5. Click the **Accept** button to close the properties configuration dialog.
6. Click the **Close** button to save your changes.

**Delete Catalog Entry**

1. In the **Options** menu, select **Catalog Manager**.
   The following dialog appears:

![Catalog Manager dialog](image)

2. Select the entry to remove from the entries table.
3. Click the **Remove Entry** button.
   A confirmation dialog appears.
4. Confirm the delete operation.
   The selected entry is removed from the XML catalog.

**XML Converter**

Support for the following XML vocabularies is included in the application:

- DITA 1.0 and 1.1
- DocBook 3.x, 4.x and 5.x
- Office Open XML (Microsoft Office 2007)
- Microsoft Visio
- Open Document Format (OpenOffice)
- SVG
- Word 2003 ML
- XHTML

Additional configurations can be added by the user as required.

**Add XML Configuration**

1. In the **Options** menu, select **XML Converter Configuration**.
   The following dialog appears:
2. Click the **Add Configuration** button. The following dialog appears:

3. Type the name of the root element of your XML files in the **Root Element** text box. The name of the root element is used to name the configuration file. The following dialog appears:

4. Click the **Add** button to add the configuration of an element. The following dialog appears:
5. Type the name of the element being added in the **Element Name** text box.

6. Select the type of element in the **Element Type** drop-down list. Available types are:
   - **segment**: the selected element starts a new section of translatable text.
   - **inline**: the selected element represents a change in formatting options and does not start a new section of translatable text.
   - **ignore**: the selected element and its children should be ignored.

7. If the element type is "inline", select the kind of formatting represented by the element in the **Inline Type** drop-down list.

8. If the element has translatable attributes, enter their names separated by a ";" in the **Translatable Attributes** text box.

9. If white space needs to be preserved when extracting text, select "Yes" in the **Keep White Space** drop-down list.

10. Click the **Save** button to save the element configuration.

11. Repeat the previous steps until all required elements have been configured.

12. Click the **Close** button to save your changes.

A new configuration file for the XML Converter is created.

**Analyze XML Sample**

A basic configuration file can be generated automatically by the application by analyzing a sample XML document. Follow these steps to create an initial configuration from an existing XML document.

1. In the **Options** menu, select **XML Converter Configuration**.
   The following dialog appears:
2. Click the **Analyze XML Sample** button.
3. Locate and open the XML file to be analyzed. The file is analyzed and the following dialog appears:

![DTD Configuration dialog](image)

4. Use the **Add**, **Edit** and **Remove** buttons to make necessary adjustments in the configuration file.
5. Click the **Close** button to save your changes.

A new configuration file based on the selected XML sample is created.

**Edit XML Configuration**

1. In the **Options** menu, select **XML Converter Configuration**.

   The following dialog appears:

   ![XML Converter Configuration dialog](image)

   2. Select the configuration file to edit from the list of available configurations.
   3. Click the **Edit Configuration** button.

   The following dialog appears:
4. Use the buttons in the **DTD Configuration** dialog to update the configuration file.
   - Use the **Add** button to add a new element to the configuration file.
   - Use the **Edit** button to modify the properties of an existing element.
   - Use the **Remove** button to delete an element from the configuration file.

5. Repeat the previous step until all elements are properly configured.

6. Click the **Close** button to save your changes.

**Delete XML Configuration**

1. In the **Options** menu, select **XML Converter Configuration**.
   The following dialog appears:

   2. Select the entry to remove from the configurations list.

   3. Click the **Remove Configuration** button.
      A confirmation dialog appears.

   4. Confirm the delete operation.
      The selected entry is removed from the list of available configuration files.
Language Codes

Standard language codes from BCP47 are used in all operations.

A list of the most common language codes is included in the program. The list of languages can be customized as needed.

Add Language

Steps for adding languages to the application

1. In Options menu, select Language Codes.
   The following dialog appears:

2. Click the Add Language button.
   The following dialog appears:

3. Type the code for the new entry in the Code text box. The code must be a valid language tag from BCP47. Language description is automatically displayed when a valid tag is entered.

4. Click the Accept button.
   A new entry is added to the list of working languages.

Edit Language

Steps for editing the properties of an existing language.

1. In Options menu, select Language Codes.
   The following dialog appears:
2. Select the entry to edit in the list of language codes.
3. Click the **Edit Language** button.
   The following dialog appears:

   ![](language_codes.png)

   - Code: es-419
   - Name: Spanish (Latin America and the Caribbean)
   - **Accept** button
   - **Cancel** button

4. Edit the language code as needed.
5. Click the **Accept** button.
   The properties of the selected language are updated.

### Delete Language
Steps for removing a language from the list of working languages.

1. In **Options** menu, select **Language Codes**.
   The following dialog appears:
2. Select the entry to delete in the list of language codes.
3. Click the **Remove Language** button.

The selected entry is removed from the list of working languages.

---

**Auto-Save Settings**

The program has the ability to automatically make a backup of the file that is open at a selected interval. Follow these steps to configure the automatic backup settings.

1. In the **Options** menu, select **Auto-Save Configuration**.
   
   The following dialog appears:

   ![Auto-Save Configuration dialog](image)

2. Check the **Enable Auto-Save** box if you want to make automatic backups. Clear it otherwise.
3. Enter the number of seconds to wait between backups in the **Interval (Seconds)** text box.
4. Click the **Accept** button.
Glossary

**Computer Aided Translation (CAT)**
Computer technology application designed to assist human translators in the translation process.

**Character Set**
A character set (sometimes referred to as code page) is a collection of characters that are associated with a sequence of natural numbers in order to facilitate the storage of text in computers and the transmission of text through telecommunication networks.

**CSV**
CSV (Comma Separated Values) is a standard file format used to store tabular data.

**SRX**
Segmentation Rules eXchange (SRX) is an XML-based open standard, published by LISA (Localization Industry Standards Association), for describing how translation and other language-processing tools segment text for processing.

**TMX**
Translation Memory eXchange (TMX) is an open standard originally published by LISA (Localization Industry Standards Association). The purpose of TMX is to allow easier exchange of translation memory data between tools and/or translation vendors with little or no loss of critical data during the process.

**Translation Memory**
Translation Memory (TM) is a language technology that enables the translation of segments (paragraphs, sentences or phrases) of documents by searching for similar segments in a database and suggesting matches that are found in the databases as possible translations.